3rd Party Cloud Provider Incident

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 05:40 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 05:36 EDT

Investigating

Some customers may experience intermittent performance issues with multiple services at this time due to our 3rd Party cloud provider.
Our engineers are aware and working to resolve this as soon as possible.
Posted Oct 20, 2025 - 05:06 EDT
This incident affected: SmartSuite (SmartAllergy, SmartDrug, SmartPharmacy, System Migrations (SmartProcessor), SmartScan, SmartSig, SmartSwitch) and Electronic Prescribing for Controlled Substances (EPCS), Huddle, Medication History (MedHx), Population Risk Management (PRM).