Intermittent Performance Issues - Electronic Prior Authorization (Myndshft)

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 14:58 EDT

Investigating

We are currently experiencing an outage with our medical eligibility verification services due to connectivity issues with our third party vendor. This is impacting Electronic Prior Authorization functionality within Myndshft.

Impact: Medical eligibility verification is currently unavailable, and customers may experience service interruptions with Electronic Prior Authorization requests.

Status: Our engineering team is actively working with our third party vendor to resolve this issue as quickly as possible. We will provide updates as they become available.

We apologize for any inconvenience this may cause and appreciate your patience while we work to restore full service.
Posted Jun 11, 2025 - 14:45 EDT
This incident affected: Electronic Prior Authorization (Myndshft) (Medical - Eligibility/Benefits Verification(BV)).