Intermittent Performance Issues - Backline

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted 1 month ago. May 05, 2025 - 13:30 EDT

Investigating

Some customers may experience intermittent performance issues with Backline at this time.
Our engineers are aware and working to resolve this as soon as possible.
Posted 1 month ago. May 05, 2025 - 13:17 EDT
This incident affected: Backline.