Intermittent Performance Issues - Backline

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 14:10 EDT

Investigating

Backline is currently experiencing latency issues. Our team is investigating and we will provide updates as soon as possible. We apologize for the inconvenience.
Posted Aug 05, 2026 - 13:27 EDT
This incident affected: Backline.