3rd Party has identified the issue. Scripts are isolated to Ohio and New York
Posted Jul 27, 2026 - 12:30 EDT
Update
We are currently investigating reports of delays in prescription routing for a subset of pharmacies in New York and Ohio, where prescriptions may take longer than expected to process and could revert to fax delivery. This appears to be related to a third party service used in prescription routing. Our team has been engaged and is actively working with the third party to identify the scope and cause. We will provide an update as soon as additional information is available.
Posted Jul 27, 2026 - 12:21 EDT
Investigating
We are currently investigating reports of delays in prescription routing for a subset of pharmacies, where prescriptions may take longer than expected to process and could revert to fax delivery. This appears to be related to a third party service used in prescription routing. Our team has been engaged and is actively working with the third party partner to identify the scope and cause. We will provide an update as soon as additional information is available.
Posted Jul 27, 2026 - 11:47 EDT
This incident affected: Third-Party Vendor Services (Pharmacy Network - Prescribing).