PDMP Third-Party Incident for Washington

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted May 19, 2026 - 13:52 EDT

Investigating

Customers may experience issues accessing Patient Searches via PDMP reports for the state Washington. We are working with our partner and will keep this page updated.
Posted May 19, 2026 - 13:34 EDT
This incident affected: Third-Party Vendor Services (PDMP).