CA CURES Connectivity Issue — PDMP Transactions Impacted

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted May 06, 2026 - 20:42 EDT

Investigating

We are currently investigating an issue affecting PDMP transactions in California. CA CURES appears to be unavailable, which is preventing PDMP checks from completing for California providers. Our team is actively investigating the root cause, including potential connectivity and traffic routing factors. We will provide an update as additional information becomes available.
Posted May 06, 2026 - 18:43 EDT
This incident affected: Third-Party Vendor Services (PDMP).