The intermittent performance issue affecting prescription routing for one pharmacy vendor has been resolved. A second pharmacy vendor is currently under investigation and our team remains engaged with the third-party routing vendor to reach resolution as quickly as possible.
Posted May 21, 2026 - 18:32 EDT
Update
A second pharmacy vendor is also experiencing the same intermittent performance issue. The third-party routing vendor is aware and our team is engaged to help resolve it as soon as possible.
Posted May 21, 2026 - 13:12 EDT
Update
We are continuing to investigate this issue.
Posted May 21, 2026 - 08:28 EDT
Update
We are continuing to investigate this issue.
Posted May 19, 2026 - 18:44 EDT
Update
We are continuing to investigate this issue.
Posted May 19, 2026 - 13:31 EDT
Update
Some customers may experience intermittent performance issues while sending prescription at this time. Our engineers are aware and working with third party vendor to resolve this as soon as possible.
Posted May 18, 2026 - 14:48 EDT
Investigating
Some customers may experience intermittent performance issues while sending prescription at this time. Our engineers are aware and working with third party vendor to resolve this as soon as possible.
Posted May 18, 2026 - 13:37 EDT
This incident affects: Third-Party Vendor Services (Pharmacy Network - Prescribing).