A fix has been implemented and we are monitoring the results.
Posted May 26, 2026 - 13:03 EDT
Update
We are aware that eligibility, medication history and prescription processing are both experiencing delays. Our team is actively engaged and taking steps to mitigate further impact. We will provide updates as more information becomes available.
Posted May 26, 2026 - 12:07 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 26, 2026 - 11:40 EDT
Update
We are aware that eligibility, medication history and prescription processing are both experiencing delays. Our team is actively engaged and taking steps to mitigate further impact. We will provide updates as more information becomes available.
Posted May 26, 2026 - 11:37 EDT
Update
We are monitoring the system and see a build up on processing prescriptions. We are engaged and the team is taking steps to mitigate further delay. We will provide an updates as soon as more information is available.
Posted May 26, 2026 - 11:16 EDT
Identified
We are monitoring the system and see a build up on processing prescriptions. We are engaged and the team is taking steps to mitigate further delay. We will provide an updates as soon as more information is available.
Posted May 26, 2026 - 10:44 EDT
Investigating
We are monitoring the system and see a build up on processing prescriptions. We are engaged and the team is taking steps to mitigate further delay. We will provide an updates as soon as more information is available.
Posted May 26, 2026 - 10:39 EDT
This incident affected: E-Prescribing Desktop (Rcopia) (E-Prescribing Desktop Region 1 (Rcopia), E-Prescribing Desktop Region 2 (Rcopia), E-Prescribing Desktop Region 3 (Rcopia), E-Prescribing Desktop Region 4 (Rcopia), E-Prescribing Desktop Region 5 (Rcopia)) and Medication History (MedHx), Prescription Routing (Gadget).