Issues with Rcopia Partner Portal
Incident Report for DrFirst
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 17:29 EST
Investigating
We are currently aware of intermittent performance issues affecting some customers using the Rcopia Partner Portal. Our engineers are actively investigating and working to resolve the issue as quickly as possible.
Posted Jan 14, 2025 - 17:04 EST
This incident affected: Rcopia (Rcopia Region 2).