Cloudflare Global Network Issues

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 14:37 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 10:46 EST

Investigating

We are currently experiencing intermittent issues with a few third-party services due to an ongoing Cloudflare outage. Our teams are actively monitoring the situation and working with affected vendors to minimize impact.
Posted Nov 18, 2025 - 09:34 EST

Update

We are currently experiencing intermittent issues with a few third-party services due to an ongoing Cloudflare outage. Our teams are actively monitoring the situation and working with affected vendors to minimize impact. We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 09:26 EST

Update

We are currently experiencing intermittent issues with a few third-party services due to an ongoing Cloudflare outage. Our teams are actively monitoring the situation and working with affected vendors to minimize impact. We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 09:21 EST

Identified

We are currently experiencing intermittent issues with a few third-party services due to an ongoing Cloudflare outage. Our teams are actively monitoring the situation and working with affected vendors to minimize impact. We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 09:16 EST

Investigating

We are currently experiencing intermittent issues with a few third-party services due to an ongoing Cloudflare outage. Our teams are actively monitoring the situation and working with affected vendors to minimize impact.
Posted Nov 18, 2025 - 09:04 EST
This incident affected: Backline, E-Prescribing Mobile (iPrescribe), Third-Party Vendor Services (EPCS IDP (Experian/ID.me)), and Support Services (Help Center & Ticket Portal).