Prescription Processing Delays — Third Party Vendor Performance Degradation

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 17:16 EDT

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 17:01 EDT

Investigating

We are currently investigating reports of prescription processing delays impacting some users. We are working with a third party pharmacy vendor to coordinate a resolution. We will provide an update as soon as more information is available.
Posted Apr 13, 2026 - 16:16 EDT
This incident affected: Prescription Routing (Gadget).