Intermittent Performance Issues - EPCS IDP (Experian/ID.me)

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 14:22 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2025 - 13:03 EST

Update

We are continuing to investigate this issue.
Posted Nov 03, 2025 - 12:28 EST

Investigating

IDP is currently experiencing an issue, which may affect your ability to authenticate or access services through the IDP. We are working with our 3rd Party vendor to resolve this as quickly as possible.
Posted Nov 03, 2025 - 11:27 EST
This incident affected: Third-Party Vendor Services (EPCS IDP (Experian/ID.me)).