Issue Submitting Tickets via Help Center

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 13:34 EDT

Investigating

We are aware of an issue that is impacting end-user ticket submission on the Requests page in the Knowledge Help Center. We are actively investigating and will provide you with an update as soon as possible.
Posted Oct 27, 2025 - 12:50 EDT
This incident affected: Support Services (Help Center & Ticket Portal).