Intermittent Performance Issues - Electronic Prior Authorization (Myndshft)

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:04 EDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 15:56 EDT

Investigating

We are currently investigating an issue impacting DrFirst's Myndshft platform due to a global outage affecting Google Cloud services.

At this time, Myndshft users may be unable to log in or access services due to failures in Google authentication (IDP, Google Cloud, Firebase). Other DrFirst systems do not appear to be affected.

We are closely monitoring the situation and will provide updates as more information becomes available.
Posted Jun 12, 2025 - 14:36 EDT
This incident affected: Electronic Prior Authorization (Myndshft) (Medical - Eligibility/Benefits Verification(BV)).