Myndshft Pharmacy Realtime Pharmacy Benefits Eligibility Issue

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 09:49 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 17:48 EDT

Investigating

We are currently investigating an issue affecting real time pharmacy benefits eligibility checks within Myndshft Pharmacy. Some users may experience errors or delays when submitting eligibility requests. We will provide updates as more information becomes available.
Posted Jul 23, 2026 - 14:11 EDT
This incident affected: Electronic Prior Authorization (Myndshft) (Pharmacy - Realtime Pharmacy Benefits(RTPB)).