Investigating Email Verification Code Delays

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 10:52 EDT

Investigating

We are currently investigating delays with email verification codes (OTP) needed for login and authentication. Some users may experience delays receiving these codes due to a service disruption with our email delivery provider. We are actively monitoring the situation and working with our provider to restore normal service. We will provide updates as more information becomes available.
Posted Sep 12, 2025 - 09:44 EDT
This incident affected: E-Prescribing Desktop (Rcopia) (E-Prescribing Desktop Region 1 (Rcopia), E-Prescribing Desktop Region 2 (Rcopia), E-Prescribing Desktop Region 3 (Rcopia)).