Investigating Email Verification Code Delays

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 11:59 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2025 - 11:21 EDT

Investigating

We are currently investigating delays with email verification codes (OTP) needed for login and authentication. Our third-party email delivery provider is experiencing a service disruption that is impacting the timely delivery of these verification codes to some users. We are in active communication with the vendor and closely monitoring their progress toward resolution. Updates will be provided as we receive additional information from our email provider.
Posted Oct 24, 2025 - 11:06 EDT
This incident affected: E-Prescribing Desktop (Rcopia) (E-Prescribing Desktop Region 1 (Rcopia), E-Prescribing Desktop Region 2 (Rcopia), E-Prescribing Desktop Region 3 (Rcopia)).