Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 05, 2026 - 23:30 EDT
Update
Updated: On Friday, June 5th, 2026 at 11:30 PM ET, DrFirst will be performing emergency system maintenance to the E-Prescribing Desktop & Mobile applications in our production environment. During the maintenance window, users may be have intermittent issues accessing the application.
For any questions, please go to help.drfirst.com or contact your DrFirst Channel Manager.
Updated: On Friday, June 5th, 2026 at 11:30 PM ET, DrFirst will be performing emergency system maintenance to the E-Prescribing Desktop application in our production environment. During the maintenance window, users may be have intermittent issues accessing the application.
For any questions, please go to help.drfirst.com or contact your DrFirst Channel Manager.
Updated: On Friday, June 5th, 2026 at 11:30 PM ET, DrFirst will be performing emergency system maintenance to the E-Prescribing Desktop application in our production environment. During the maintenance window, users may be have intermittent issues accessing the application.
For any questions, please go to help.drfirst.com or contact your DrFirst Channel Manager.
Updated: On Friday, June 5th, 2026 at 11:30 PM ET, DrFirst will be performing emergency system maintenance to the E-Prescribing Desktop application in our production environment. During the maintenance window, users may be have intermittent issues accessing the application.
For any questions, please go to help.drfirst.com or contact your DrFirst Channel Manager.
This scheduled maintenance affected: E-Prescribing Desktop (Rcopia) (E-Prescribing Desktop Region 1 (Rcopia), E-Prescribing Desktop Region 2 (Rcopia), E-Prescribing Desktop Region 3 (Rcopia), E-Prescribing Desktop Region 4 (Rcopia), E-Prescribing Desktop Region 5 (Rcopia)) and E-Prescribing Mobile (iPrescribe).