Intermittent Performance Issues - Electronic Prior Authorization (Myndshft)

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 14:46 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 23, 2026 - 13:18 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 23, 2026 - 12:42 EST

Investigating

DrFirst is aware of an issue affecting Electronic Prior Authorization (Myndshft) that may cause intermittent performance degradation for some customers. Our engineering team is actively investigating and working toward a resolution.
Posted Feb 23, 2026 - 12:09 EST
This incident affected: Electronic Prior Authorization (Myndshft) (Medical - Patient Financial Responsibility(PFR), Medical - Prior Auth Requirements(PAR), Medical - Prior Auth Submission(PAS), Pharmacy - Realtime Pharmacy Benefits(RTPB)).