Intermittent Performance Issues with Rcopia, iPrescribe & EPCS
Incident Report for DrFirst
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 16:09 EST
Investigating
Some customers may experience intermittent performance issues with Rcopia, iPrescribe & EPCS at this time.
Our engineers are aware and working to resolve this as soon as possible.
Posted Jan 14, 2025 - 15:48 EST
This incident affected: Rcopia (Rcopia Region 1, Rcopia Region 2, Rcopia Region 3, Rcopia Region 4, Rcopia Region 5) and EPCS, iPrescribe.