Total Benefits (Price Transparency) service performance degradation due to third party PBM outage

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 14:27 EDT

Monitoring

We have completed the internal changes to disable PBM connections. We are now actively monitoring system stability and will re-enable the connections once PBM services have been confirmed as stable.
Posted Oct 29, 2025 - 14:18 EDT

Identified

We are making internal changes to disable the PBM connections until their services are stabilized.
Posted Oct 29, 2025 - 14:06 EDT

Investigating

Some customers may experience performance issues with Total Benefits (Price Transparency) at this time due to a third party PBM outage.
Posted Oct 29, 2025 - 13:56 EDT
This incident affected: Total Benefits (Provider Solutions) (Price Transparency (mBc)).